Problems with PayPal / Information missing from the invoice document

Problem

Information from third-party plugins is missing from the invoice document.

This can be, for example, a different bank account or payment information from PayPal Invoice Purchase or another payment provider plugin.

Root Cause

  • If the invoice is generated synchronously with order completion, information may still be missing during document generation to adjust the document accordingly.
  • The PayPal plugin, for example, reports the payment status and payment references asynchronously via IPN webhook, which is why this information may only be available several minutes after the order is received

Troubleshooting

1. Check that the plugin and system cron job is set up correctly

For more information, see .

2. Exclude the affected payment methods from synchronous processing

Navigate to the plugin settings and add the payment method (e.g. PayPal) to the "Exclude payment method from synchronous processing" field:

Screenshot 2021-04-17 at 16.06.04.png

The adjustment only applies to new orders after the time of the change. You may need to manually recreate invoices for orders that have already been received.

Advanced Troubleshooting

If the steps mentioned above do not resolve your issue, read the article on  Advanced Troubleshooting.

Was this helpful?